Back to overview
Downtime

Network outage

Mar 8, 2026 at 4:54am UTC

Resolved
Mar 8, 2026 at 7:39am UTC

We're back! Things are operational again. Apologies for any inconvenience caused by the outage.

Updated
Mar 8, 2026 at 6:40am UTC

Network outage was resolved. But looks like there's another outage. Will investigate and attempt to bring back online.

Created
Mar 8, 2026 at 4:54am UTC

We are currently experiencing a network outage at our data centre. Our team is actively working to restore services, with an estimated recovery time of approximately one hour. We apologize for the inconvenience and will provide updates as available.